Lucid Platform Services Incident Alert: Latency with our services
Incident Report for Lucid System Status
Resolved
This incident has been resolved.
Posted Dec 01, 2022 - 13:44 UTC
Monitoring
We’re monitoring the resolution of the incident.
Posted Dec 01, 2022 - 13:15 UTC
Investigating
We’re investigating reports of latency and delays with Marketplace UI and our APIs. Users may experience difficulties while loading pages and performing updates across the pages on our platform.
Posted Dec 01, 2022 - 12:39 UTC
This incident affected: Marketplace (Marketplace UI, Marketplace Login) and Core Services (Prescreener, Respondent Tracker, Marketplace API).