Degraded Performance of Marketplace API, Marketplace UI, and Respondent Experience
Incident Report for Lucid System Status
Resolved
This issue has been resolved. If you made any changes to your surveys during this period of degraded performance, please confirm that all changes have been saved to avoid any disruptions in fielding. Please reach out to our Support team if you're still experiencing any issues.
Posted May 23, 2023 - 15:47 UTC
Monitoring
To ensure the integrity of our services, we are monitoring the state of the impacted components. After stability is confirmed, we will consider this issue resolved.
Posted May 23, 2023 - 15:23 UTC
Identified
We have identified the cause of the issue and are working to provide a resolution. We will continue to provide updates when new information is available.
Posted May 23, 2023 - 15:06 UTC
Investigating
We are investigating reports of errors and latency within the Marketplace UI, Marketplace API, and the Respondent Experience. Users of the components impacted may experience slowness or inability to load pages and a possible increase in api request response times.

Engineering is aware and actively investigating both root cause and a forward path. We will continue to provide updates when new information is available.
Posted May 23, 2023 - 14:04 UTC
This incident affected: Marketplace (Marketplace UI) and Core Services (Prescreener, Respondent Tracker, Marketplace API).