Marketplace UI Slowness
Incident Report for Lucid System Status
Resolved
This issue has been resolved. Please reach out to our Support team if you're still experiencing any issues.
Posted Mar 13, 2023 - 17:01 UTC
Identified
We have identified the cause of the issue. Our Authentication partner is experiencing elevated errors which may cause some users to experience slowness in loading pages. We will continue to provide updates when new information is available.
Posted Mar 13, 2023 - 16:48 UTC
Investigating
We are investigating reports of Marketplace UI slowness. Users of the components impacted may experience errors or slowness when loading pages.

Engineering is aware and actively investigating both root cause and a forward path. We will continue to provide updates when new information is available.
Posted Mar 13, 2023 - 16:22 UTC
This incident affected: Marketplace (Marketplace UI, Marketplace Login).