Lucid Platform Services Incident Alert for Impact Measurement Reporting
Incident Report for Lucid System Status
Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 21:53 UTC
Investigating
We are receiving reports of degraded performance for Impact Measurement visualizations. We are investigating the issue and will report an update as soon as possible
Posted Jan 13, 2023 - 16:01 UTC
This incident affected: Audience (Impact Measurement).