Lucid Platform Services Incident Alert for Survey Details Page
Incident Report for Lucid System Status
Resolved
A fix has been implemented and this issue has been confirmed as resolved.
Posted Apr 15, 2021 - 13:14 UTC
Investigating
We have received reports and are investigating an issue where users are unable to update surveys using the survey details page. This issue is isolated to the Marketplace UI and is not affecting the respondent experience.
Posted Apr 15, 2021 - 12:49 UTC
This incident affected: Marketplace (Marketplace UI).