Lucid Platform Services Incident Alert for Monetization Link
Incident Report for Lucid System Status
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 16:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2022 - 16:36 UTC
Investigating
We are investigating an issue where Link respondents are experiencing increased load times or timeouts when entering the respondent experience. We’ll send an update once the issue is identified.
Posted Nov 17, 2022 - 15:43 UTC
This incident affected: Core Services (Prescreener, Monetization API, Monetization Link).