Lucid Platform Services Incident Alert
Incident Report for Lucid System Status
Resolved
This incident has been resolved.
Posted Jul 26, 2022 - 14:54 UTC
Monitoring
We’re monitoring the resolution of the incident.
Posted Jul 26, 2022 - 14:41 UTC
Investigating
We’re investigating reports of latency and slowness with Marketplace UI pages. We’ll send an update once the issue is identified.
Posted Jul 26, 2022 - 14:31 UTC
This incident affected: Marketplace (Marketplace UI).